546
you are viewing a single comment's thread
view the rest of the comments
[-] Octopus1348@lemy.lol 3 points 11 months ago

It's much more readable when you use else depending on the checks. You can still use return in an else block.

def Allowed()

  if name == "Octopus1348": return True

  elif name == "Bobert": return True

  else:
        return "You are not allowed to use this script."

print(Allowed())

`

this post was submitted on 16 Jan 2024
546 points (98.8% liked)

Programmer Humor

19910 readers
1765 users here now

Welcome to Programmer Humor!

This is a place where you can post jokes, memes, humor, etc. related to programming!

For sharing awful code theres also Programming Horror.

Rules

founded 2 years ago
MODERATORS